Найти индексы элементов массива, значение которых принадлежит диапазону (КуМир)

Тема: 
Массивы

Программа создает массив случайных целых чисел, запрашивает у пользователя минимум и максимум и далее просматривает элементы массива. Если значение элемента (x) удовлетворяет условию min <= x <= max, то выводится на экран номер элемента (индекс) в массиве.

алг индексы_массива
нач
  цел таб array[1:50]
  цел minimum,maximum
  цел i
  нц для i от 1 до 50
    array[i] := int(rnd(100))
    вывод array[i], ' '
    если mod(i,10) = 0 то 
      вывод нс
    все
  кц
  вывод нс
  вывод 'Минимум: '; ввод minimum
  вывод 'Максимум: '; ввод maximum
  вывод 'Индексы элементов: '
  нц для i от 1 до 50
    если array[i] >= minimum и array[i] <= maximum то 
      вывод i, ' '
    все
  кц
кон

Примерный результат работы программы:

82 26 47 31 69 46 18 32 46 43 
63 20 6 14 24 47 16 53 79 30 
14 21 67 47 43 12 91 82 27 83 
47 97 64 39 73 63 41 44 42 31 
54 37 8 56 27 32 39 71 7 82 
 
Минимум: 50
Максимум: 60
Индексы элементов: 18 41 44