Функция перевода десятичного числа в двоичную систему счисления (среда программирования КуМир)

Тема: 
Функции

В функцию binary передается целое число в десятичной системе счисления, а сама функция возвращает строку, которая представляет собой двоичное выражение переданного числа. В теле функции сначала создается пустая строка. В ее начало в цикле добавляется преобразованный к строковому типу остаток от деления десятичного числа на 2. После нахождения остатка само число делится нацело на 2. Цикл завершается, когда число сокращается до 0. При этом будет сформирована строка - представление числа в двоичной системе счисления.

В главном алгоритме реализован цикл, в котором вызывается функция с переданным ей числом, которое вводит пользователь. Цикл завершается, если пользователь вводит 0.

алг 
нач
  цел num
  нц пока да
    ввод num
    если num <> 0 то
      вывод binary(num), нс
     иначе
      выход
    все
  кц
кон
 
алг лит binary(цел n)
нач
  лит c
  цел m 
  m := n
  знач := ""
  нц пока m > 0 
    c := цел_в_лит(mod(m,2))
    знач := c + знач
    m := div(m,2)
  кц
кон

Пример выполнения программы:

33
100001
333
101001101
3333
110100000101
33333
1000001000110101
0