Вывести день недели в зависимости от значения функции (КуМир)

Тема: 
Условный оператор

Найти остаток от деления целой части значения функции y = ln(x²+ab) на 7 и, в зависимости от его величины, напечатать сообщение об одном из дней недели, пронумеровав их от 0 до 6. Значения переменных а, b, x получить случайным образом на произвольном интервале (границы интервала ввести с клавиатуры).

Особенности решения задачи:

Выражение rnd(m-s) + s генерирует случайное число от s до m. В среде КуМир встроенная функция rnd выдает случайное вещественное число от 0 до переданного ей аргумента. Если вычесть из максимума минимум, то мы тем самым определим размер диапазона. Если потом прибавить минимум, то диапазон сместится от 0 к указанному минимуму.

алг день недели
нач
  вещ s, m, a, b, x, y
  цел n
  вывод "Min: "; ввод s
  вывод "Max: "; ввод m
  a := rnd(m-s) + s
  b := rnd(m-s) + s
  x := rnd(m-s) + s
  y := ln(x**2 + a*b)
  n := int(y)
  n := mod(n,7)
  выбор
    при n = 0: вывод "Понедельник"
    при n = 1: вывод "Вторник"
    при n = 2: вывод "Среда"
    при n = 3: вывод "Четверг"
    при n = 4: вывод "Пятница"
    при n = 5: вывод "Суббота"
    при n = 6: вывод "Воскресенье"
  все
кон

Пример выполнения программы:

Min: 1.2
Max: 1.9
Вторник