Найти сумму и произведение цифр трехзначного числа (КуМир)

Тема: 
Линейные алгоритмы

Найти сумму и произведение цифр случайного трехзначного числа.

Алгоритм решения задачи:

  1. Сгенерировать случайное число от 100 до 999.
  2. Вывести его на экран.
  3. Получить цифру сотен, разделив нацело на 100.
  4. Получить цифру десяток, разделив нацело на 10, а затем по модулю на 10.
  5. Получить цифру единиц, разделив по модулю на 10.

алг сумма цифр
нач
  цел n,a,b,c
  n := int(rnd(900)) + 100
  вывод n, " ", нс
  a := div(n,100)
  b := mod(div(n,10),10)
  c := mod(n,10)
  вывод "Сумма: ", a+b+c, нс
  вывод "Произведение: ", a*b*c, нс
кон

Пример выполнения программы:

183 
Сумма: 12
Произведение: 24