Деление большего числа на меньшее (среда программирования КуМир)

Тема: 
Функции

Вводятся два натуральных числа. Требуется нацело разделить большее на меньшее. Если числа не делятся нацело без остатка, то следует вывести и остаток.

В программе деление нацело и нахождение остатка вынесено в отдельный алгоритм. Так удобнее, так как не надо повторять один и тот же код для двух различных ситуаций: а) когда первое число больше второго и б) когда второе больше первого. Таким образом в основном алгоритме узнается, какое число больше, и в зависимости от этого алгоритм "деление" вызывается либо с одним порядком аргументов, либо с другим.

В самом алгоритме "деление" сначала находится частное от целочисленного деления. После чего проверяется, нет ли остатка отличного от нуля. Если он есть, то выводится после частного в скобках.

алг 
нач
  цел a, b
  ввод a, b
  если a > b то деление(a, b)
   иначе 
    деление(b, a)
  все
кон
 
алг деление(цел большее, меньшее)
нач
  вывод большее, " : ", меньшее, " = ", div(большее, меньшее)
  если mod(большее,меньшее) <> 0 то
    вывод "(", mod(большее, меньшее),")"
  все
кон

Примеры выполнения программы:

560 45
560 : 45 = 12(20)
78 8700
8700 : 78 = 111(42)
5 135
135 : 5 = 27