Найти сумму n-элементов ряда 1, -0.5, 0.25, -0.125, ... (Кумир)

Тема: 
Циклы

Дан ряд чисел 1, -0.5, 0.25, -0.125, ... Требуется найти сумму стольких его элементов, сколько указал пользователь. Например, если n = 3, то надо сложить 1, -0.5, 0.25, что в результате даст 0.75.

В предложенном числовом ряде каждое целое число в 2 раза меньше предыдущего по модулю и противоположно по знаку. Значит, чтобы получить следующее число, надо предыдущее разделить на 2 и умножить на -1.

Алгоритм решения задачи:

  1. Присвоим переменной вещественного типа первое число ряда.
  2. Создадим переменную для накопления суммы элементов ряда (также вещественного типа).
  3. Выполним цикл n раз и будем выполнять нижеследующие действия.
  4. К сумме будем добавлять значение текущего элемента.
  5. Изменим значение текущего элемента на то, которое должно быть следующим (разделим на -2).

Примечание. В среде программирования КуМир нельзя записать выражение так: a/-2. Можно: -a/2.

алг сумма ряда 
нач
  цел n, i 
  вещ a, sum
  ввод n
  a := 1
  sum := 0
  нц для i от 1 до n 
    sum := sum + a
    a := -a / 2
  кц
  вывод sum
кон

Примеры выполнения программы:

4
0.625
10
0.6660156