Найти сумму и количество элементов последовательности больших по модулю 0.001 (КуМир)

Тема: 
Циклы

Найти сумму и количество элементов последовательности, которые по модулю больше 0.001. Последовательность: 1/2 - 2/4 + 3/8 - 4/16 + ... - ...

Обозначение переменных:

  • n - счетчик количества элементов ряда
  • sum - накапливаемая сумма элементов ряда
  • a - числитель дроби числа
  • b - знаменатель дроби числа
  • mark - знак числа

Алгоритм решения задачи:
Пока дробь больше 0.001 выполнять нижеследующие действия.

  1. Добавить к сумме числитель деленный на знаменатель и умноженный на знак (1 или -1).
  2. Изменить числитель, добавив к нему 1.
  3. Изменить знаменатель, умножив его на 2.
  4. Изменить знак на противоположный
  5. Увеличить на 1 счетчик элементов ряда.

алг сумма ряда 
нач
  цел n, a, b, mark
  вещ sum
  a := 1
  b := 2
  mark := 1
  sum := 0
  n := 0
  нц пока a/b > 0.001 
    sum := sum + mark * a / b
    a := a + 1 
    b := b * 2
    mark := -mark
    n := n + 1
  кц
  вывод sum, нс
  вывод n
кон

Результат выполнения:

0.2227783
13