Посчитать четные и нечетные цифры числа (среда КуМир)

Тема: 
Циклы

В среде программирования КуМир функция mod() находит остаток от деления первого аргумента на второй. Фунция div() делит нацело первый аргумент на второй.

Если число делится без остатка на 2, значит оно четное, поэтому увеличивается значение переменной, в которой хранится количество четных цифр числа.

Если число не является четным, значит оно нечетное. Поэтому увеличивается на единицу переменная, в которой хранится значение количества нечетных цифр.

Чтобы избавиться от учтенной цифры, делим число нацело на 10. Понятно, что учет цифр производится с конца числа.

алг цифры_числа 
нач
  цел а
  цел чет,нечет
  чет := 0
  нечет := 0
  ввод а
  нц пока а > 0
    если mod(а,2) = 0
      то чет := чет + 1
      иначе нечет := нечет + 1
    все
    а := div(а,10)
  кц
  вывод "Четных: ", чет, нс
  вывод "Нечетных: ", нечет
кон