Вычисление факториала (КуМир)

Тема: 
Циклы

Факториал числа - это произведение всех натуральных чисел до числа, факториал которого находим. Так факториал числа 4 равен 1 * 2 * 3 * 4, что равно 24. В матиматике это записали бы так: 4! = 1 * 2 * 3 * 4 = 24.

Напишем программу, вычисляющую факториал натурального числа, которое вводит пользователь. При вводе чисел не следует вводить большие числа, т.к. уже факториал числа 13 выходит за диапазан допустимых целых чисел в среде программирования КуМир.

Алгорим решения задачи:

  1. Присвоим переменной factorial значение 1.
  2. Будем умножать значение этой переменной на каждое последующее натуральное число до числа (включая его), которое ввел пользователь.

алг факториал
нач
  цел factorial
  цел n, i
  ввод n
  factorial := 1;
  нц для i от 2 до n
    factorial := factorial * i
  кц
  вывод factorial
кон

Примеры выполнения кода:

7
5040
10
3628800
13
>> 11:19:53 - Новая программа* - ОШИБКА ВЫПОЛНЕНИЯ: Целочисленное переполнение 

Немного доработаем

Немного доработаем программку, чтобы не выводилась ошибка о целочисленном переполнении

алг факториал
нач
  цел factorial
  цел n, i
  ввод n
если n > 12 то
вывод "Введите значение не превышающее 12"
выход
иначе
  factorial := 1;
  нц для i от 2 до n
    factorial := factorial * i
  кц
все
  вывод factorial
кон