Таблица значений функции (КуМир)

Тема: 
Циклы

Вычислить значение функции y = sqrt(x)/2 - 0.5 на указанном отрезке с заданным шагом (пределы отрезка и шаг вводит пользователь).

Алгоритм решения задачи:

  1. Пока значение первой точки (x) меньше значения второй
  2. вычислять значение y по формуле,
  3. выводить на экран пару x и y,
  4. изменять x на величину заданного шаг.

алг функция 
нач
  вещ x1, x2, step, y
  ввод x1
  ввод x2
  ввод step
  нц пока x1 <= x2
    y := sqrt(x1) / 2 - 0.5
    вывод x1,  '  |  ',  y,  нс
    x1 := x1 + step
  кц
кон

Пример выполнения программы:

4
6
0.2
4  |  0.5
4.2  |  0.5246951
4.4  |  0.5488089
4.6  |  0.5723805
4.8  |  0.5954451
5  |  0.618034
5.2  |  0.6401754
5.4  |  0.661895
5.6  |  0.6832159
5.8  |  0.7041595