Возведение натуральных чисел в степень (КуМир)

Тема: 
Циклы

Возвести последовательность натуральных чисел в степень, пока степень очередного числа не превысит заданного значения.

Пользователь вводит показатель степени и предел возведения в степень.

Алгоритм решения задачи:

  1. Последовательно перебираются натуральные числа, начиная с 1 и до числа, степень которого не больше заданного предела.
  2. Степень натурального числа выводится на экран.
  3. Переходим к следующему числу.

В среде КуМир операция возведения в степень обозначается двумя звездочками (**).

алг степень 
нач
  цел p,n,i
  вывод "Показатель степени: "
  ввод p
  вывод "Предел: "
  ввод n
  i := 1 
  нц пока i**p <= n
    вывод i**p, ' '
    i := i + 1
  кц
кон

Пример выполнения программы:

Показатель степени: 4
Предел: 1500
1 16 81 256 625 1296