Вывод таблицы символов (КуМир)

Тема: 
Циклы

В среде программирования Кумир (школьный алгоритмический язык программирования) есть две таблицы кодировки символов: КОИ-8 и Юникод. Чтобы получить символ по его коду в кодировке КОИ-8, надо использовать функцию символ(). Для кодировки Юникод существует функция символ2().

Программа ниже сначала выводит на экран все символы от 32-го до 255 из кодировки КОИ-8. А затем только буквы русского алфавита и их коды из кодировки Юникод.

Переменная j и инструкция если введены исключительно для придания табличного вида выводу.

Функция юникод() возвращает код переданного ей символа.

алг таблица символов
нач
  цел i
  нц для i от 32 до 255
    вывод символ(i),' '
  кц
  вывод нс, нс
  цел first, last, j
  first := юникод('А')
  last := юникод('я')
  j := 0
  нц для i от first до last
    вывод i, '-', символ2(i),' '
    j := j + 1
    если mod(j,10) = 0 то
      вывод нс
    все
  кц
кон

Результат выполнения программы:

  ! " # $ % & ' ( ) * + , - . / 0 1 2 3 4 5 6 7 8 9 : ; < = > ? @ A B C D E F G 
H I J K L M N O P Q R S T U V W X Y Z [ \ ] ^ _ ` a b c d e f g h i j k l m n o 
p q r s t u v w x y z { | } ~ ⊠ ─ │ ┌ ┐ └ ┘ ├ ┤ ┬ ┴ ┼ ▀ ▄ █ ▌ ▐ ░ ▒ ▓ ⌠ ■ ∙ √ ≈ 
≤ ≥   ⌡ ° ² · ÷ ═ ║ ╒ ё ╓ ╔ ╕ ╖ ╗ ╘ ╙ ╚ ╛ ╜ ╝ ╞ ╟ ╠ ╡ Ё ╢ ╣ ╤ ╥ ╦ ╧ ╨ ╩ ╪ ╫ ╬ © 
ю а б ц д е ф г х и й к л м н о п я р с т у ж в ь ы з ш э щ ч ъ Ю А Б Ц Д Е Ф Г 
Х И Й К Л М Н О П Я Р С Т У Ж В Ь Ы З Ш Э Щ Ч Ъ 
 
1040-А 1041-Б 1042-В 1043-Г 1044-Д 1045-Е 1046-Ж 1047-З 1048-И 1049-Й 
1050-К 1051-Л 1052-М 1053-Н 1054-О 1055-П 1056-Р 1057-С 1058-Т 1059-У 
1060-Ф 1061-Х 1062-Ц 1063-Ч 1064-Ш 1065-Щ 1066-Ъ 1067-Ы 1068-Ь 1069-Э 
1070-Ю 1071-Я 1072-а 1073-б 1074-в 1075-г 1076-д 1077-е 1078-ж 1079-з 
1080-и 1081-й 1082-к 1083-л 1084-м 1085-н 1086-о 1087-п 1088-р 1089-с 
1090-т 1091-у 1092-ф 1093-х 1094-ц 1095-ч 1096-ш 1097-щ 1098-ъ 1099-ы 
1100-ь 1101-э 1102-ю 1103-я