Определение количества строк, слов и символов в файле (КуМир)

Тема: 
Файлы

Дан файл с произвольным текстом. Требуется посчитать в нем количество строк, слов и символов.

Переменные:

  • f - переменная, связанная с файлом
  • line - количество строк
  • word - количество слов
  • char - количество символов
  • in - находимся ли мы внутри слова?
  • s - очередная строка из файла

Алгоритм:

  1. Открыть файл на чтение и связать с переменной f.
  2. Пока не наступит конец файла f выполнять:
    1. получить очередную строку;
    2. увеличить на 1 значение line;
    3. измерить с помощью функции длин() длину строки (количество символов в ней) и добавить полученное значение к переменной char;
    4. присвоить in 0, т.е. мы находимся вне слова;
    5. перебирая все символы строки, если очередной символ не пробел и in = 0, то увеличивать счетчик слов (word) на 1 и присваивать in 1 (находимся внутри слова); иначе проверить, если очередной символ пробел, присвоить in 0.
  3. Закрыть файл
  4. Вывести значения переменных line, word, char на экран.

использовать Файлы П
алг 
нач
  цел f, line, word, char, in, i
  лит s
  line := 0
  word := 0
  char := 0
  f := открыть на чтение ("текст.txt")
  нц пока не конец файла (f)
    Фввод f, s
    line := line + 1
    вывод s, нс
    char := char + длин(s)
    in := 0
    нц для i от 1 до длин(s) 
      если s[i] <> " " и in = 0 то
        word := word + 1
        in := 1
       иначе
        если s[i] = " " то in := 0 все
      все
    кц
  кц
  закрыть(f)
  вывод нс, "строк - ", line, нс
  вывод "слов - ", word, нс
  вывод "символов - ", char
кон

Привет, Мир!
Hello World!
5, 4 ...

строк - 3
слов - 7
символов - 32