Задача расчета величин выплат по кредиту (КуМир)

Тема: 
Линейные алгоритмы

Рассчитать ежемесячные выплаты по кредиту по формуле:
m = (n * p * (1 + p)y) / (12 * ((1 + p)y – 1)), где
m - ежемесячная выплата;
n - сумма кредита;
p - проценты, выраженные в долях единицы;
y - количество лет, на которые взят кредит.

Вычислить суммарную (за все года) выплату банку.

алг кредит
нач
  цел n,y
  вещ p,m,s
  вывод "Сумма кредита: "
  ввод n
  вывод "Период: "
  ввод y
  вывод "Проценты: "
  ввод p
  p := p / 100
  m := (n * p * (1 + p)**y) / (12 * ((1+p)**y - 1))
  s := m * 12 * y
  вывод "Ежемесячная выплата: ", m, нс
  вывод "Суммарная выплата: ", s, нс
кон

Пример выполнения программы:

Сумма кредита: 1000000
Период: 20
Проценты: 15
Ежемесячная выплата: 13313.46
Суммарная выплата: 3195229