Найти максимальные элементы строк и столбцов матрицы (КуМир)

Тема: 
Массивы

В матрице целых чисел найти максимальные элементы в каждой строке и в каждом столбце. Вывести на экран саму матрицу. Максимумы строк должны быть выведены в конце каждой строки матрицы. Максимумы столбцов - под своими столбцами.

Будем искать максимумы строк сразу при заполнении массива, так как заполняться он будет построчно. Перед заполнением каждой строки присвоим переменной, в которой будет храниться максимум, значение меньше минимально возможного для данного массива. Заполняя строку, будем сравнивать значение очередного элемента строки матрицы с тем, что записано в переменной. Если элемент больше, то присвоим его переменной-максимуму. После заполнения строки выведем найденный максимум.

При поиске максимумов в столбцах внешний цикл будет проходить по столбцам, а внутренний по элементам столбцов. На каждой итерации внешнего цикла переменной-максимуму присвоим первый элемент столбца. Если при проходе по столбцу, начиная
со второго элемента, какой-то элемент окажется больше, чем сохраненный в переменной-максимуме, то следует в нее сохранить найденный больший. После выполнения внутреннего цикла вывести найденный максимум, при этом не переходить на новую строку.

алг
нач
  цел N = 10, M = 15
  целтаб t[1:N,1:M]
  цел mx, i, j
  нц для i от 1 до N
    mx := -1 * МАКСЦЕЛ - 1
    нц для j от 1 до M
      t[i,j] := irnd(100) - irnd(100)
        вывод t[i,j]:4
        если t[i,j] > mx то
          mx := t[i,j]
        все
    кц
    вывод " | ", mx, нс
  кц
  нц для i от 1 до M 
    вывод "  _ "
  кц
  вывод нс
  нц для j от 1 до M
    mx := t[1, j]
    нц для i от 2 до N
      если t[i,j] > mx то
        mx := t[i,j]
      все 
    кц
    вывод mx:4
  кц
кон

Пример работы программы:

  58  -3  49  76   7 -10  -2  68 -45  41  51 -44 -30 -70  -3 | 76
  -1 -60  16 -42 -17   4 -15 -55 -39  43 -57   9   2 -21  52 | 52
  49  37 -10  82  28 -18   7  30  37  -8  51 -21 -38  50  -2 | 82
  -5 -45 -65  19   0 -26 -32 -42  89  -1 -39  54  81 -27  -7 | 89
   8  34 -71  26  57  28  27 -45  43 -50  19  42 -83 -52  -9 | 57
  40 -13 -20  33 -58  75  -5  39 -12 -18   8  19 -23  64  21 | 75
 -55   0 -89 -14 -43 -15  57  17 -16  67   2  31 -42  61   4 | 67
 -58 -20  15 -34  -1  80  12  12   7 -75  -5  -8 -48  -4  -4 | 80
  35   8  18  31 -54  -3   2  69  18  29 -65 -62 -18  11 -44 | 69
 -31 -48 -36  51 -17 -11 -42 -42   9 -16 -72 -28  19  34 -21 | 51
  _   _   _   _   _   _   _   _   _   _   _   _   _   _   _ 
  58  37  49  82  57  80  57  69  89  67  51  54  81  64  52