Максимальный элемент и его индекс в массиве (КуМир)

Тема: 
Массивы

В массиве целых чисел найти максимальный элемент и его индекс. Вывести на экран элементы массива, заключив в скобки максимальный. Под массивом вывести позицию (индекс) наибольшего элемента.

При заполнении массива сразу будем искать максимум. Поскольку требуется найти не только максимальный элемент, но и его позицию в массиве, то можно искать исключительно позицию (индекс) этого элемента. Зная индекс, всегда можно получить значение. Присвоим переменной mx (в которой будет храниться индекс максимального значения) значение 1. Это значит, предполагается, что максимальный элемент является первым элементом массива. При заполнении массива, если очередной элемент больше того, который хранится под индексом mx, то следует присвоить текущий индекс (i) переменной mx.

При выводе элементов массива на экран, если номер (индекс) текущего элемента совпадает со значением mx, то обрамить его скобками. В конце программы вывести значение mx - позицию (индекс) максимального элемента.

алг
нач
  цел N = 20
  целтаб arr[1:N]
  цел mx, i
  mx := 1
  нц для i от 1 до N
    arr[i] := irnd(1000)
    если arr[mx] < arr[i] то
      mx := i
    все
  кц
  нц для i от 1 до N
    если mx = i то
      вывод "[",arr[i], "] "
     иначе
      вывод arr[i], " "
    все
  кц
  вывод нс,"Позиция: ", mx
кон

326 142 717 593 70 59 753 93 704 400 616 25 29 [922] 786 504 67 601 327 226 
Позиция: 14