Найти расстояние между точками в n-мерном пространстве (КуМир)

Тема: 
Циклы

Даны координаты A1, A2, ..., An одной точки и координаты B1, B2, ..., Bn другой точки n-мерного пространства. Найти расстояние между ними по формуле sqrt(sqr(A1-B1) + ... + sqr(An-Bn)).

Более правильно задачу решать с использованием массивов. Сначала запросить все координаты точки A, затем - B. После этого выполнять вычисления. Программа ниже - упрощенный вариант: сначала запрашиваются координаты x обоих точек, потом - координаты y и т. д.

алг расстояние
нач
цел n,i,a,b,sum
  вещ sq
  вывод "n-мерное пространство, n = "
  ввод n
  sum := 0
  нц для i от 1 до n 
    вывод 'a',i,' = '
    ввод a
    вывод 'b',i,' = '
    ввод b
    sum := sum + (a - b)**2
  кц
  sq := sqrt(sum)
  вывод "Расстояние между точками: ", sq
кон

Пример работы программы:

n-мерное пространство, n = 3
a1 = 1
b1 = 6
a2 = 2
b2 = -5
a3 = -1
b3 = 6
Расстояние между точками: 11.09054