Посчитать количество введенных простых чисел (КуМир)

Тема: 
Циклы

Пользователь вводит натуральные числа. Определить сколько было введено среди них простых чисел.

Алгоритм решения задачи:

  1. Пока вводятся числа больше 1
  2. установить флаговую переменную в значение 'да';
  3. перебрать все числа от 2 до квадратного корня из введенного числа и проверить каждое, делит ли оно нацело введенное число;
  4. если да, то установить флаговую переменную в значение 'нет' и прекратить проверку;
  5. если флаговая переменная так и осталась в значении 'да', то значит введенное число простое и следует увеличить счетчик простых чисел на 1.

алг простые числа
нач
  цел n, i, count
  лог f
  ввод n
  count := 0
  нц пока n > 1
    f := да
    нц для i от 2 до int(sqrt(n))
      если mod(n,i) = 0 то
        f := нет
        выход
      все 
    кц
    если f то
      count := count + 1
    все
    ввод n
  кц
  вывод "Количество простых чисел:", count
кон

100
101
37
18
10234
52
13
19
110
1
Количество простых чисел:4