Найти корни квадратного уравнения по переданным коэффициентам (КуМир)

Тема: 
Условный оператор

Найти корни квадратного уравнения по переданным коэффициентам a, b, c, которые вводит пользователь.

Алгоритм решения задачи:

  1. Вычислить дискриминант.
  2. Если он больше нуля, то вычислить два корня уравнения,
  3. иначе, если дискриминант равен нулю, то вычислить единственный корень уравнения,
  4. иначе вывести сообщение, что корней нет.

алг квадратное уравнение
нач
  вещ a, b, c, D, x1, x2
  ввод a
  ввод b
  ввод c
  D := b**2 - 4*a*c
  вывод "D = ", D, нс
  если D > 0 то
    x1 := (-b + sqrt(D)) / (2 * a)
    x2 := (-b - sqrt(D)) / (2 * a)
    вывод "x1 = ", x1, нс
    вывод "x2 = ", x2, нс
   иначе
    если D = 0 то
      x1 := -b / (2 * a)
      вывод "x = ", x1, нс
     иначе
      вывод "корней нет", нс
    все
  все
кон

Пример выполнения программы:

-1.2
-3.5
1
D = 17.05
x1 = -3.178819
x2 = 0.2621519