Поместить в массив положительные элементы другого массива, стоящие на четных местах (КуМир)

Тема: 
Массивы

Из одного массива вещественных чисел поместить в другой только положительные элементы, стоящие на четных местах (имеющие четные индексы).

Алгоритм решения задачи:

  1. В цикле из массива A проверять только элементы, имеющие четный индекс (т. е. на каждой итерации цикла надо увеличивать счетчик на 2 и начать нужно со второго элемента: i = 2).
  2. Если элемент массива A больше нуля, но увеличить счетчик элементов массива B на 1 и положить по данному индексу число в массив B.

алг фильтр массива 
нач
  вещ таб arrA[1:20], arrB[1:20]
  цел i, j
  вывод "Массив A:", нс
  нц для i от 1 до 20
    arrA[i] := rnd(10) - 5
    вывод arrA[i], '   '
  кц
 
  вывод нс, "Массив B:", нс
  i := 2
  j := 0
  нц пока i <= 20 
    если arrA[i] > 0 то
      j := j + 1
      arrB[j] := arrA[i]
      вывод arrB[j], '   '
    все
    i := i + 2
  кц
кон

Пример выполнения программы:

Массив A:
-1.506851   1.197089   -1.510819   4.966124   1.779077   3.69808   2.599719   
1.71926   2.487411   4.001434   -1.590167   2.117222   3.84579   4.16654   
-0.4881436   1.070437   -0.9443953   -4.215979   2.544176   -0.5693228   
Массив B:
1.197089   4.966124   3.69808   1.71926   4.001434   2.117222   4.16654   
1.070437