Определить длину самого короткого слова в строке (КуМир)

Тема: 
Строки

В строке, состоящей из слов, написанных строчными русскими буквами, найти длину самого короткого слова. Слова могут быть разделены одним или несколькими пробелами.

Алгоритм решения задачи:

  1. Присвоить переменной l длину строки.
  2. Пусть переменая w обозначает длину слова, чья длина измеряется в данный момент.
  3. В переменной min_w будет храниться длина самого короткого слова. В начале минимуму присваивают максимально возможное значение. Если представить, что вся строка состоит из одного слова, то самое большое значение min_w может быть равно l.
  4. По очереди (в цикле) перебираем все символы строки:
  5. Если очередной символ буква, то увеличиваем на единицу значение w.
  6. Иначе сравниваем w и min_w, и если w меньше, то изменяем значение min_w на его значение.
  7. Кроме того, в любом случае в ветке "иначе" обнуляем значение w, т.к. начнется новое слово.

алг замена подстрок
нач
  лит string
  цел w, min_w, i, l
 
  ввод string
  l := длин(string)
 
  w := 0
  min_w := l
  нц для i от 1 до l
    если string[i]>='а' и string[i]<='я' то
      w := w + 1
     иначе 
       если w < min_w и w <> 0 то
         min_w := w
       все
       w := 0
    все
  кц
 
  вывод min_w
кон

где живет бегемот
3