Проверка гипотезы Сиракуз (КуМир)

Тема: 
Циклы

Возьмем любое натуральное число. Если оно четное, то разделим его на 2. Если оно нечетное, то умножим на 3, прибавим 1 и затем разделим на 2. Результат этих операций также будем проверять на четность и выполнять первое или второе действие. Гипотеза Сиракуз утверждает, что рано или поздно мы получим из единицу.

Напишем программу, которая проверяет гипотезу Сиракуз для числа, которое вводит пользователь. Пока число не сведется к единице будем либо делить его на 2 (если оно четно), либо умножать на 3, прибавлять 1 и делить на 2. Если гипотеза Сиракуз верна, то рано или поздно цикл остановится.

алг сиракуз
нач
  цел n
  ввод n
  нц пока n <> 1
    если mod(n,2) = 0 то
      n := div(n,2)
     иначе
      n :=  div((3*n+1),2)
    все
    вывод n, ' '
  кц
кон

Пример выполнения программы:

111
167 251 377 566 283 425 638 319 479 719 1079 1619 2429 3644 1822 911 1367 2051 3077 4616 2308 1154 577 866 433 650 325 488 244 122 61 92 46 23 35 53 80 40 20 10 5 8 4 2 1

Задача

А что значит "нц", "кц"?