Функции вычисления площадей фигур (среда программирования КуМир)

Тема: 
Функции

Написать алгоритмы, которые вычисляют площади различных геометрических фигур. В основном алгоритме программы вызвать один из них в зависимости от выбора пользователя.

В основном алгоритме можно ввести переменную, в зависимости от значения которой будет вызываться тот или иной алгоритм. Значение переменной будет определяться вводом с клавиатуры.

В программе ниже алгоритмам не передаются параметры. Все необходимые для вычисления площади данные запрашиваются внутри вызываемых алгоритмов. В основной алгоритм возвращается полученная площадь. И здесь она выводится на экран.

алг площадь фигуры
нач
  сим фигура
  вывод "Круг(к), прямоугольник(п), треугольник(т): "
  ввод фигура
  если фигура = "к" то
    вывод круг
   иначе
    если фигура = "п" то
      вывод прямоугольник
     иначе
      если фигура = "т" то
        вывод треугольник
      все
    все
  все
кон
 
алг вещ круг
нач
  вещ р
  вывод "Радиус: "
  ввод р
  знач := 3.14 * р**2
кон
алг вещ прямоугольник
нач
  вещ д, ш
  вывод "Длина: "
  ввод д
  вывод "Ширина: "
  ввод ш
  знач := д * ш
кон
алг вещ треугольник
нач
  вещ п, а, б, в 
  вывод "Сторона 1: "
  ввод а
  вывод "Сторона 2: "
  ввод б
  вывод "Сторона 3: "
  ввод в
  п := (а + б + в) / 2
  знач := sqrt(п * (п - а) * (п - б) * (п - в))
кон

Примеры выполнения программы:

Круг(к), прямоугольник(п), треугольник(т): к
Радиус: 2.1
13.8474
Круг(к), прямоугольник(п), треугольник(т): п
Длина: 3.5
Ширина: 5.1
17.85
Круг(к), прямоугольник(п), треугольник(т): т
Сторона 1: 4
Сторона 2: 3
Сторона 3: 6
5.332682