Найти n-ое слово в строке (КуМир)

Тема: 
Строки

Найти в строке слово под определенным номером и вывести на экран его первый символ. Номер слова вводится пользователем.

Особенности решения задачи:

  1. Пусть переменная count является счетчиком слов. Присвоим ей сначала 0, т.к. строка может не содержать ни одного слова.
  2. Переменная flag пусть обозначает, находимся ли мы внутри очередного слова или вне слова. Если значение flag 1, то очередной символ это продолжение прежнего слова. Когда встречается пробел flag присваивается 0, что означает, что далее можно засчитывать новое слово в count.
  3. Просматривать символы необходимо до тех пор, пока count не станет равным номеру искомого слова.

алг номер слова 
нач
  лит s
  цел n,l,count, flag, i
  ввод s
  вывод "Номер слова: "
  ввод n
  l := длин(s)
  count := 0
  flag := 0
  нц для i от 1 до l
    если s[i]<>' ' и flag = 0 то
      count := count + 1
      flag := 1
      если count = n то 
        выход
      все
    все
    если s[i] = ' ' то
      flag := 0
    все
  кц 
  вывод s[i]
кон

Пример выполнения:

salf cmdkf woeru
Номер слова: 2
c

Ответ!

Подскажите ответ для проверки!