Создание файла и запись данных в него (среда программирования КуМир)

Тема: 
Файлы

Указанный пользователем файл открывается на запись. Далее в цикле запрашивается ввод строк, которые записываются в открытый файл. Если вводится строка, состоящая из одного символа "!", то файл закрывается и происходит выход из цикла. Это единственный способ выйти из цикла, так как цикл задан как бесконечный.

Команда "Фвывод", также как и команда "вывод", не выводит символа новой строки. Поэтому, чтобы в файле введенные данные были разделены на строки, в программе две команды "Фвывод". Одна выводит в файл строку, другая - задает новую строку.

использовать Файлы П
алг 
нач
  цел ф
  лит имя, строка
  вывод "Имя файла: "
  ввод имя
  ф := открыть на запись (имя)
  вывод "Вводите строки ниже:", нс
  нц пока да
    ввод строка
    если строка = "!" то
      закрыть(ф)
      выход
    все
    Фвывод ф, строка
    Фвывод ф, нс
  кц
кон