Программа-калькулятор (КуМир)

Тема: 
Циклы

Написать программу, выполняющую арифметические операции (сложение, вычитание, умножение и деление) над двумя вещественными числами. Программа должна выполняться в цикле до тех пор, пока пользователь не введет определенный знак.

Одной из особенностей решения является то, что символьная переменная, в которую записывается знак операции, играет также роль сигнала о прекращении вычислений. Поэтому пользователю предлагается сначала ввести знак операции, а потом уже числа, если не был введен символ, сигнализирующий о завершении операций.

алг простейший калькулятор
нач
  вещ x,y
  сим s
  нц пока да 
    вывод "Знак: "
    ввод s
    если s='0' то выход все
    если s='+' или s='-' или s='*' или s='/' то
      вывод "x="
      ввод x
      вывод "y="
      ввод y
      выбор 
        при s='+': вывод x+y, нс
        при s='-': вывод x-y, нс
        при s='*': вывод x*y, нс
        при s='/': 
          если y=0 то вывод "Деление на ноль!", нс
           иначе вывод x/y, нс
          все
      все
     иначе
      вывод "Неверный знак операции", нс
    все
  кц
кон

Пример выполнения программы

Знак: +
x=5.67
y=-4
1.67
Знак: /
x=5
y=0
Деление на ноль!
Знак: )
Неверный знак операции
Знак: /
x=3
y=10
0.3
Знак: 0