Заменить три последних символа у слов, больших определенной длины (КуМир)

Тема: 
Строки

Дан массив слов. У слов, которые состоят более чем из 5-ти символов, заменить три последних символа на символ '$'.

Основная часть алгоритма решения задачи:

  1. Измеряем длину очередного элемента массива, т.е. очередного слова, и сохраняем ее в переменной l.
  2. Если значение l больше 5-ти, то присвоить переменной w это слово, затем взять из него срез от первого символа до четвертого с конца (-3) и присоединить к срезу символ '$'. Получившееся слово записать в массив вместо исходного слова.

алг замена подстрок
нач
  лит таб string[1:7]
  лит w
  цел i,l
  нц для i от 1 до 7 
    ввод string[i]
  кц
 
  нц для i от 1 до 7 
    l := длин(string[i])
    если l > 5 то
      w := string[i]
      string[i] := w[1:l-3] + "$"
    все
  кц
 
  нц для i от 1 до 7 
    вывод string[i], " "
  кц
кон

Пример выполнения кода:

Привет
Василек
Перфоратор
Кто
Провал
лодка
жидкий
При$ Васи$ Перфора$ Кто Про$ лодка жид$