Найти уравнение прямой, проходящей через заданные точки (КуМир)

Тема: 
Линейные алгоритмы

Найти уравнение прямой по координатам двух точек, лежащих на этой прямой. Координаты вводит пользователь.

Прямые описываются уравнением y = kx + b. Другими словами, надо найти коэффициенты k и x. Если известны координаты двух точек, лежащих на прямой, то найти эти коэффициенты можно решая систему уравнений:

| y1 = kx1 + b
| y2 = kx2 + b
b = y2 - kx2
y1 = kx1 + y2 - kx2
k = (y1 - y2) / (x1 - x2)
b = y2 - k*x2

Таким образом, мы получили формулы для вычисления k и b.

алг уравнение_прямой
нач
вещ x1, y1, x2, y2, k, b
вывод "Координаты точки A(x1;y1): "
ввод x1, y1
вывод "Координаты точки B(x2;y2): "
ввод x2, y2
k := (y1 - y2) / (x1 - x2)
b := y2 - k * x2
вывод "Уравнение прямой: y = " + вещ_в_лит(k) + "x + " + вещ_в_лит(b)
кон

Примеры выполнения кода:

Координаты точки A(x1;y1): 4 9
Координаты точки B(x2;y2): -1 -3
Уравнение прямой: y = 2.4x + -0.6

Координаты точки A(x1;y1): 0 0
Координаты точки B(x2;y2): 2.5 -4.85
Уравнение прямой: y = -1.94x + 0