Вычислить площадь и периметр треугольника, прямоугольника и круга (КуМир)

Тема: 
Линейные алгоритмы

Площади и периметры фигур вычисляются по следующим формулам:

Периметр треугольника:
P = a + b + c

Площадь треугольника:
S = √(p(p-a)(p-b)(p-c)), где p = P/2

Периметр прямоугольника:
P = 2(a + b)

Площадь прямоугольника:
S = ab

Периметр круга:
P = 2πr

Площадь круга:
S = πr2

алг фигуры
нач
  цел a,b,c
  ввод a, b, c
  вещ p, S
  p := (a+b+c)/2
  S := sqrt(p*(p-a)*(p-b)*(p-c))
  вывод "P=", p*2, "; S=", S, нс
 
  цел w, h
  ввод w, h
  вывод "P=", (w+h)*2, "; S=", w*h, нс
 
  цел r
  ввод r
  p := 2 * 3.14 * r
  S := 3.14 * r**2
  вывод "P=", p, "; S=", S, нс
кон

Пример выполнения программы:

5 7 9
P=21; S=17.41228
4 9
P=26; S=36
5
P=31.4; S=78.5