Найти самую длинную последовательность максимальных элементов в массиве (КуМир)

Тема: 
Массивы

В массиве, состоящем из нулей и единиц, найти самую длинную непрерывную последовательность единиц. Вывести на экран индексы по массиву первой и последней единицы найденной последовательности.

Алгоритм решения задачи:

  1. Если очерередной элемент массива равен 1, то увеличивать счетчик количества подряд идущих единиц.
  2. Если очередной элемент массива не равен 1, то сохранить значение счетчика в переменной, где хранится размер самой длинной последовательности, только если там хранится меньшее значение. Также запомнить индекс элемента, после которого последовательность оборвалась.
  3. Когда встречается не единица, обнулять значение счетчика подряд идущих единиц.

алг  максимальная последовательность
нач
  цел таб arr[1:50]
  цел i, count, max_count, id
  нц для i от 1 до 50
    arr[i] := int(rnd(2))
    вывод arr[i], ' '
    если mod(i,10) = 0 то вывод нс все
  кц
 
  count := 0
  max_count := 0
  id := 0
  нц для i от 1 до 50
    если arr[i] = 1 то count := count + 1 
     иначе
       если count > max_count то 
         max_count := count
         id := i - 1
       все
       count := 0
    все
  кц
  вывод "[", id-(max_count-1),";",id,"]"
кон

Пример выполнения программы:

0 0 1 0 0 1 1 0 0 0 
1 1 0 0 0 0 1 1 0 0 
1 0 0 1 0 1 1 1 1 1 
0 0 1 1 0 1 0 1 1 0 
1 0 1 1 0 0 0 1 0 0 
[26;30]