Заменить последний элемент строки матрицы, на сумму предыдущих элементов строки (КуМир)

Тема: 
Массивы

В заданной матрице необходимо заменить последний элемент каждой строки на сумму предыдущих элементов данной строки.

Алгоритм решения задачи:

  1. "Заходим" в очередную строку.
  2. Присваиваем переменной summa значение 0 (сначала сумма элементов строки равна нулю).
  3. Перебираем все элементы строки.
  4. Если индекс элемента не является последним, то добавляем значение элемента к сумме.
  5. Иначе (когда индекс указывает на последний элемент строки матрицы) изменяем значение последнего элемента на найденную сумму.

алг сумма строки матрицы 
нач
  цел таб matrix[1:4, 1:6]
  цел i, j, summa
  нц для i от 1 до 4
    нц для j от 1 до 6 
      matrix[i,j] := int(rnd(10))
      вывод matrix[i,j], " "
    кц
    вывод нс
  кц
  вывод нс
 
  нц для i от 1 до 4
    summa := 0
    нц для j от 1 до 6 
      если j < 6 
       то
         summa := summa + matrix[i,j]
       иначе
         matrix[i,j] := summa
      все
      вывод matrix[i,j], " "
    кц
    вывод нс
  кц
кон

6 1 5 5 6 5 
0 7 4 1 5 7 
4 7 3 3 8 6 
1 6 0 8 5 2 
 
6 1 5 5 6 23 
0 7 4 1 5 17 
4 7 3 3 8 25 
1 6 0 8 5 20

Можно обойтись без конструкции если-иначе:

нц для i от 1 до 4
  summa := 0
  нц для j от 1 до 5 
    summa := summa + matrix[i,j]
    вывод matrix[i,j], " "
  кц
  matrix[i,6] := summa
  вывод matrix[i,6], " "
  вывод нс
кц