Найти произведение и сумму цифр натурального числа (КуМир)

Тема: 
Циклы

Найти сумму и произведение всех ненулевых цифр числа. Например, вводится число 5032; сумма его цифр равна 10, произведение - 30.

Алгоритм решения задачи:

  1. Ввести исходное число (n).
  2. Присвоить переменной sum (сумма) значение 0.
  3. Присвоить переменной mult (произведение) значение 1 (нуль присваивать нельзя, иначе все произведение будет равно нулю).
  4. Пока число n больше нуля, делать нижеследующее:
  5. найти остаток от деления n на 10,
  6. если этот остаток не равен нулю, то добавить его к сумме и умножить на него произведение,
  7. разделить число n нацело на 10.
  8. Вывести накопленные сумму и произведение.

алг сумма_произведение_цифр	
нач
  цел n, mult, sum
  вывод "Введите число: "; ввод n
  mult := 1
  sum := 0
  нц пока n > 0 
    если mod(n,10)<> 0 то
      mult := mult * mod(n,10)
      sum := sum + mod(n,10)
    все
    n := div(n,10)
  кц
  вывод "Произведение цифр: ", mult, нс
  вывод "Сумма цифр: ", sum, нс
кон

Пример выполнения программы:

Введите число: 5069
Произведение цифр: 270
Сумма цифр: 20