Определить возможность существования треугольника и его тип (КуМир)

Тема: 
Условный оператор

По трем введенным сторонам надо сказать, возможно ли существование такого треугольника и если да, то какой он: разносторонний, равнобедренный или равносторонний.

Треугольник существует только тогда, когда никакая его сторона не больше и не равна сумме длин других сторон. Только в этом случае имеет смысл продолжить программу на определение типа треугольника.

Самая сложная проверка - это проверка на равнобедренность треугольника, т.к. в этом случае надо проверить равенство любых двух сторон и их неравенство третьей. Проще всего проверить, что все стороны не равны друг другу (разносторонний треугольник), или что все стороны равны (равносторонний треугольник). И если ни первый, ни второй вариант не вернули истину, то останется только один вариант - равнобедренный треугольник.

алг треугольник
нач
  цел a,b,c
  ввод a,b,c
  если (a+b)<=c или (a+c)<=b или (b+c)<=a то
    вывод "Треугольник не существует"
   иначе
    если (a<>b) и (a<>c) и (b<>c) то
      вывод "Разносторонний треугольник"
     иначе
      если (a=b) и (b=c) то
        вывод "Равносторонний треугольник"
       иначе
        вывод "Равнобедренный треугольник"
      все
    все
  все
кон

Пример выполнения программы:

56 45 43
Разносторонний треугольник