Перевернуть число (КуМир)

Тема: 
Циклы

Вводится число. Требуется вывести его так, чтобы составляющие его цифры шли в обратном порядке. Например, вводится число 4096, надо вывести 6904.

  1. Если найти остаток от деления на 10, то мы получим последнюю цифру числа.
  2. Запишем эту цифру в новое число.
  3. Разделим старое число нацело на 10, так мы избавимся от последней цифры в нем.
  4. Снова найдем остаток от деления на 10. Получим вторую с конца цифру исходного числа.
  5. Если мы умножим новое число на 10, то получим "дополнительный" младший разряд, куда можем записать вторую цифру исходного числа (простым сложением).
  6. Будем повторять вышеописанные действия пока исходное число не станет равным нулю.

алг перевернуть число
нач
  цел число, нов_число
  ввод число
  нов_число := 0
  нц пока число > 0
    нов_число := нов_число * 10 + mod(число,10)
    число := div(число,10)
  кц
  вывод нов_число
кон

Примеры выполнения кода:

895401
104598

89450
5498